1053 Path of Equal Weight (30分)

Given a non-empty tree with root R, and with weight W**i assigned to each tree node T**i. The weight of a path from *R* to *L* is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

img

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<230, the given weight number. The next line contains N positive numbers where W**i (<1000) corresponds to the tree node T**i. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1,A2,⋯,A**n} is said to be greater than sequence {B1,B2,⋯,B**m} if there exists 1≤k<min{n,m} such that A**i=B**i for i=1,⋯,k, and A**k+1>B**k+1.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

题目描述:现在有一棵树,让你找到根结点到叶子结点总权值为给定值的路径。


输入:n:节点总数,m:非叶子结点个数;s:假定要求的根节点到叶子节点总权值;接下来m行,包括id:结点编号,k:子结点个数,接下来k个子结点编号。

输出:根结点到叶子结点的过程中经过的总权值等于s,输出所经过结点的权值。


解题思路:这道题不用建树,用有向图保存这棵树就行。可以用BFS算法或DFS算法。

这里列举BFS算法详解:每个结点的权值保存在weight数组中,边的关系保存在G邻接表中。从root结点层层遍历,很简单的就可以得到根节点到各个叶子结点的总权值了。最重要的还是输出顺序的问题,我先将符合条件的路径权值数组存入ans二维数组容器中,最后将二维数组进行排序。排序规则是每个数组中同一位置的权值最大的序列排在前面输出。


//BFS 广度优先
#include<bits/stdc++.h>
using namespace std;
struct node{
	int id;
	long long ss;
	vector<int> list;
	node(){
		ss = 0;
	}
};
int n, m;
long long s;
const int maxn = 220;
int weight[maxn];
vector<int> G[maxn];
vector< vector<int> > ans;
bool cmp(vector<int> a, vector<int> b){
	int l=0;
	l = min(a.size(),b.size());
	for(int i=0; i<l; i++){
		if(a[i]==b[i]) continue;
		else return a[i] > b[i];
	}
	return false; //如果没有,最后一个测试点段错误! 
}
void bfs(int root){
	node t, tt;
	queue<node> q;
	t.id = root; t.ss = weight[root];
	t.list.push_back(weight[root]);
	q.push(t);
	
	int u, v;
	while(!q.empty()){
		t = q.front();
		u = t.id;
		q.pop();
		if(t.ss==s&&G[u].size()==0){
			ans.push_back(t.list);
			continue;
		}
		else if(t.ss > s) continue;
		for(int i=0; i<G[u].size(); i++){
			v = G[u][i];
			tt.id = v; tt.ss = t.ss + weight[v]; tt.list = t.list;
			tt.list.push_back(weight[v]);
			q.push(tt);
		}
	}
	sort(ans.begin(),ans.end(),cmp);
	
	for(int i=0; i<ans.size(); i++){
		for(int j=0; j<ans[i].size(); j++){
			if(j) printf(" ");
			printf("%d", ans[i][j]);
		}
		printf("\n");
	}
}
int main()
{
	scanf("%d %d %lld", &n, &m, &s);
	int id, k, g;
	for(int i=0; i<n; i++) scanf("%d", &weight[i]);
	for(int i=0; i<m; i++){
		scanf("%d %d", &id, &k);
		for(int j=0; j<k; j++){
			scanf("%d", &g);
			G[id].push_back(g);
		}
	}
	bfs(0);
	return 0;
}
//DFS 深度优先
#include<bits/stdc++.h>
using namespace std;
struct node{
	int w;
	vector<int> child;
};
vector<node> v;
vector<int> path;
int target;
void dfs(int index, int nodenum, int sum){
	if(sum>target) return ;
	if(sum==target){
		if(v[index].child.size()!=0) return;
		for(int i=0; i<nodenum; i++){
			printf("%d%c", v[path[i]].w, i!=nodenum-1?' ':'\n');
		}
		return;
	}
	for(int i=0; i<v[index].child.size(); i++){
		int nd = v[index].child[i];
		path[nodenum] = nd;
		dfs(nd,nodenum+1,sum+v[nd].w);
	}
}
int cmp(int a, int b){
	return v[a].w > v[b].w;
}
int main()
{
	int n, m, node, k;
	scanf("%d %d %d", &n, &m, &target);
	v.resize(n), path.resize(n);
	for(int i=0; i<n; i++){
		scanf("%d", &v[i].w);
	}
	for(int i=0; i<m; i++){
		scanf("%d %d", &node, &k);
		v[node].child.resize(k);
		for(int j=0; j<k; j++) scanf("%d", &v[node].child[j]);
		sort(v[node].child.begin(),v[node].child.end(),cmp);
	}
	dfs(0,1,v[0].w);
	return 0;
}