1062 Talent and Virtue (25分)
About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people's talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a "sage(圣人)"; being less excellent but with one's virtue outweighs talent can be called a "nobleman(君子)"; being good in neither is a "fool man(愚人)"; yet a fool man is better than a "small man(小人)" who prefers talent than virtue.
Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang's theory.
Input Specification:
Each input file contains one test case. Each case first gives 3 positive integers in a line: N (≤105), the total number of people to be ranked; L (≥60), the lower bound of the qualified grades -- that is, only the ones whose grades of talent and virtue are both not below this line will be ranked; and H (<100), the higher line of qualification -- that is, those with both grades not below this line are considered as the "sages", and will be ranked in non-increasing order according to their total grades. Those with talent grades below H but virtue grades not are cosidered as the "noblemen", and are also ranked in non-increasing order according to their total grades, but they are listed after the "sages". Those with both grades below H, but with virtue not lower than talent are considered as the "fool men". They are ranked in the same way but after the "noblemen". The rest of people whose grades both pass the L line are ranked after the "fool men".
Then N lines follow, each gives the information of a person in the format:
ID_Number Virtue_Grade Talent_Grade
where ID_Number
is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.
Output Specification:
The first line of output must give M (≤N), the total number of people that are actually ranked. Then M lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade, they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID's.
Sample Input:
14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60
Sample Output:
12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90
题目描述:有个人制定了规则,给定了天赋美德的评分界限,大于等于H的为优秀,小于H的为一般。他将人分为了四类,称天赋(talent)和美德(virtue)都优秀的人“圣人”;virtue优秀但talent一般的人为“君子”;virtue和talent都一般,但virtue分数高于等于talent分数的人为“愚人”;virtue和talent都一般,而且virtue分数低于talent分数的人为“小人”。
输入:第一行三个输入数据,N(<=105)需要排序的总人数,L分等级时的最低分数,H分等级时的优秀界限。接下来的n行,每行输入3个数,分别为ID_Number、Virtue_Grade、Talent_Grade。
输出:第一行输出一个参与排序的总人数,接着依照指定的排序规则,依序输出“圣人”、“君子”、“愚人”、“小人”。排序规则:先按照virtue+talent的总得分递减排序;当总分相同,则按照virtue得分递减排序;当总分相同、virtue得分相同,则按照ID递增排序。
解题思路:先过滤不符合排序的人,就是talent或virtue分数小于最低分数界限L的人。将四类人分为A、B、C、D四组;组分好后,进行排序,最后输出。
A--talent >= H, virtue >= H;
B--talent <H , virtue >= H;
C--talent < H, virtue < H && virtue >= talent;
D--talent < H, virtue <H && virtue < talent;
#include<bits/stdc++.h>
using namespace std;
int n, l, h;
struct node{
int id;
int virtue, talent;
int cid;
};
vector<node> v;
bool cmp(node a, node b){
if(a.cid!=b.cid) return a.cid < b.cid;
else if(a.virtue+a.talent != b.virtue+b.talent) return a.virtue+a.talent > b.virtue+b.talent;
else if(a.virtue!=b.virtue) return a.virtue > b.virtue;
else if(a.id!=b.id) return a.id < b.id;
}
int main()
{
scanf("%d %d %d", &n, &l, &h);
for(int i=0; i<n; i++){
node t;
scanf("%d %d %d", &t.id, &t.virtue, &t.talent);
if(t.talent<l||t.virtue<l) continue;
if(t.talent>=h&&t.virtue>=h) t.cid = 1;
else if(t.talent<h&&t.virtue>=h) t.cid = 2;
else if(t.talent<h&&t.virtue<h&&t.virtue>=t.talent) t.cid = 3;
else t.cid = 4;
v.push_back(t);
}
sort(v.begin(),v.end(),cmp);
printf("%d\n", v.size());
for(int i=0; i<v.size(); i++){
node t = v[i];
printf("%d %d %d\n", t.id, t.virtue, t.talent);
}
return 0;
}