1065 A+B and C (64bit) (20分)
Given three integers A, B and C in [−263,263], you are supposed to tell whether A+B>C.
Input Specification:
The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.
Output Specification:
For each test case, output in one line Case #X: true
if A+B>C, or Case #X: false
otherwise, where X is the case number (starting from 1).
Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
Sample Output:
Case #1: false
Case #2: true
Case #3: false
题目描述:A+B>C,真返回true,假返回false
解题思路:一看就是大数据处理,long double类型杠,或者对数据处理一下
注:a>>1 与 a/2有区别,(a&1) 与 a%2有区别,a+b==c 与 (g=a+b),g==c有区别
方法一:
#include<bits/stdc++.h>
using namespace std ;
int main()
{
int n;
scanf("%d", &n);
for( int i=1; i<=n; i++){
long double a, b, c;
scanf("%Lf %Lf %Lf", &a, &b, &c);
printf("Case #%d: ", i);
if(a+b>c) printf("yes\n");
else printf("false\n");
}
return 0 ;
}
方法二:
#include<bits/stdc++.h>
using namespace std;
int main()
{
long long a, b, c;
int n;
scanf("%d", &n);
for(int i=1; i<=n; i++){
scanf("%lld %lld %lld", &a, &b, &c);
long long ta, tb, tc;
ta = a>>1;
tb = b>>1;
tc = c>>1;
printf("Case #%d: ", i);
if(ta+tb>tc){
printf("true\n");
}
else if(ta+tb==tc&&((a&1)+(b&1)>(c&1))){
printf("true\n");
}
else printf("false\n");
}
return 0;
}
方法三:
n = int(input())
for i in range(1,n+1):
g = input().split()
a = int(g[0])
b = int(g[1])
c = int(g[2])
if a+b > c:
print('Case #{}: true'.format(i))
else:
print('Case #{}: false'.format(i))