1067 Sort with Swap(0, i) (25分)

Given any permutation of the numbers {0, 1, 2,..., N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (≤105) followed by a permutation sequence of {0, 1, ..., N−1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

题目描述:只能与0交换,求得到正确序列所需最少交换次数。

解题思路:找到序列中值与位置不匹配的元素,进行循环交换,将他们放回正确的位置,当该元素不为0时,交换次数要另外加2。


#include<bits/stdc++.h>
using namespace std;
int main()
{
	int n;
	vector<int> v;
	scanf("%d", &n);
	v.resize(n);
	for(int i=0; i<n; i++){
		scanf("%d", &v[i]);
	}
	int ans = 0;
	for(int i=0; i<n; i++){
		if(v[i]==i) continue;
		while(v[i]!=i){
			swap(v[i],v[v[i]]);
			ans++;
		}
		if(i!=0) ans+=2;
	}
	printf("%d\n", ans);
	return 0;
}