1069 The Black Hole of Numbers (20分)

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,104).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

题目描述:有一个小于10000的数n,n中的每一个数字重新排序,可以组成最大数和最小数,例如1001,可以重新排序得到max=1100,min=0011,用max - min得到的值进行循环,最终会得到6174或0000。现在就是要将求得6174或0000的过程模拟出来。


输入:小于10000的数

输出:输出max - min的计算结果为6174或0000的过程


解题思路:利用sscanf和sprintf两个函数进行模拟,使用字符的形式进行排序。注意以数字形式输出是,不满4 digits在前面要补0。


#include<bits/stdc++.h>
using namespace std;
int main()
{
	int val1, val2;
	int n;
	scanf("%d", &n);
	char s[10];
	while(n){
		sprintf(s, "%04d", n);// 发送格式化输出到 s
		sort(s,s+4);
		sscanf(s, "%d", &val2);//从字符串读取格式化输入 s -> val2
		reverse(s,s+4);
		sscanf(s, "%d", &val1);//s ->val1
		int g = val1 - val2;
		printf("%04d - %04d = %04d\n", val1, val2, g);
		if(g==0 || g==6174) break;
		n = g;
	}
	return 0;
}