1075 PAT Judge (25分)
The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.
Input Specification:
Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤104), the total number of users, K (≤5), the total number of problems, and M (≤105), the total number of submissions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i]
(i
=1, ..., K), where p[i]
corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:
user_id problem_id partial_score_obtained
where partial_score_obtained
is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]
]. All the numbers in a line are separated by a space.
Output Specification:
For each test case, you are supposed to output the ranklist in the following format:
rank user_id total_score s[1] ... s[K]
where rank
is calculated according to the total_score
, and all the users with the same total_score
obtain the same rank
; and s[i]
is the partial score obtained for the i
-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.
The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.
Sample Input:
7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0
Sample Output:
1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -
题目描述:PAT的成绩排序,排序规则(总分递增排序;总分相同,完美解答题目数多者优先;前两者都相同时,id递增排序)
输入:第一行三个参数。n为参赛人数,k为总题数,M为参赛者答题情况数。下列m行,每行三个参数,分别为参赛者id,题号,答题所得分数
输出:输出有分数的参赛者参赛的排名、id、总分、各题得分。
解题思路:emmmm后续再长篇大论解释,现在先写一些注意事项
注意:
测试点2:编译未通过者得分为-1,不计入得分,编译通过者,但是得分为0,成绩记为0。有一参赛者1,他所有题目都编译未通过,他得分岁为0,但不将他计入排名。有一参赛者2,他只编译通过了1道题,但这道题成绩为0,而且他的其他题都编译未通过,那他与参赛者1是不同的,他是可以计入排名的。
测试点4:有些人,某道题已经提交过并且为满分了,他又去提交了一次,那么,他这第二次提交的满分记录,不计入完美答题数中。
#include<bits/stdc++.h>
using namespace std;
int n, k, m;
const int maxn = 1e5+1;
int score[maxn];
struct node{
int id;
int b[6];//记录每道题的分数
int all_score;
int TG;
int perfit_count;//记录完美答题个数
node(){
TG = all_score = 0;
perfit_count = 0;
memset(b,-1,sizeof(b));
}
};
map<int,node> p;
map<int,int> vis;
vector<node> v;
bool cmp(node a, node b){
if(a.all_score!=b.all_score) return a.all_score > b.all_score;
else if(a.perfit_count!=b.perfit_count) return a.perfit_count > b.perfit_count;
else return a.id < b.id;
}
int main()
{
int A, B, C;
scanf("%d %d %d", &n, &k, &m);
for(int i=1; i<=k; i++) scanf("%d", &score[i]);
for(int i=0; i<m; i++){
scanf("%d %d %d", &A, &B, &C);
if(vis[A]==0){//没有记录过,把他添加到map中
node t;
if(C==-1) C=0;
else t.TG = 1;
t.id = A;
t.all_score = C;
t.b[B] = C;
if(C==score[B]){//标记B题已经满分
t.perfit_count++;
}
vis[A] = 1;
p[A] = t;
}
else{//该学生之前已经答过题了
node t;
t = p[A];
if(C==-1) C=0;
else t.TG = 1;
if(t.b[B]==-1){//第B道题没有回答过
t.b[B] = C;
t.all_score += C;
if(C==score[B]){//标记B题已经满分
t.perfit_count++;
}
}
else if(C>t.b[B]){
t.all_score -= t.b[B];
t.all_score += C;
t.b[B] = C;
if(C==score[B]){//标记B题已经满分
t.perfit_count++;
}
}
p[A] = t;
}
}
map<int,node>::iterator it;
node t;
for(it=p.begin(); it!=p.end(); it++){
t = it->second;
if(t.TG) v.push_back(t);
}
sort(v.begin(),v.end(),cmp);
int rank = 1, tscore=0;
for(int i=0; i<v.size(); i++){
t = v[i];
if(i==0) tscore = t.all_score;
if(t.all_score!=tscore){
rank = i+1;
tscore = t.all_score;
}
printf("%d %05d %d", rank, t.id, t.all_score);
for(int j=1; j<=k; j++){
if(t.b[j]==-1) printf(" -");
else printf(" %d", t.b[j]);
}
printf("\n");
}
return 0;
}