1079 Total Sales of Supply Chain (25分)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (≤105), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N−1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

K**i ID[1] ID[2] ... ID[K**i]

where in the i-th line, K**i is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. K**j being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after K**j. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1010.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3

Sample Output:

42.4

题目描述:有一条销售链,供应商、经销商、零售商,供应商提供货物给经销商,经销商提供货物给零售商,题目要求出零售商售出的总额是多少。0号索引表示供应商。供应商的售价p,经销商的售价p1 = r%*p,零售商售价p2 = r%*p1。


输入:第一行三个数,n为节点数,p为商品原价,即供应商的出价,r为售价的增幅。接下来n行(表示0~n-1个结点的情况),分两种情况

1)第一个值为0,第二个值就表示零售商需要销售商品的数量

2)第一个值不为0,则第一个值表示第i个结点的子结点个数m,后面接着m个子结点的编号。

输出:零售商售出的总额,保留一位小数


解题思路:典型的bfs题,使用邻接表存树,节约空间。

注意,题目给的是r,我们计算时要计算r%,所以r*1.0/100。


#include<bits/stdc++.h>
using namespace std;
int n;
double p, r;
const int maxn = 200005;
vector<int> G[maxn];
map<int,int> lvs_sell;
struct node{
	int index;
	double price;
};
void bfs(){
	node t, tt;
	t.index = 0; t.price = p;
	queue<node> q;
	q.push(t);
	double ans = 0;
	while(!q.empty()){
		t = q.front();
		q.pop();
		if(G[t.index].size()==0){
			ans += lvs_sell[t.index]*t.price;
		}
		else{
			for(int i=0; i<G[t.index].size(); i++){
				int v = G[t.index][i];
				tt.index = v;
				tt.price = r*t.price;
				q.push(tt);
			}
		}
	}
	printf("%.1f", ans);
}
int main()
{
	scanf("%d %lf %lf", &n, &p, &r);
	r = r*1.0/100 + 1;
	int a, b;
	for(int i=0; i<n; i++){
		scanf("%d %d", &a, &b);
		if(a==0) lvs_sell[i] = b;
		else{
			G[i].push_back(b);
			for(int j=1; j<a; j++){
				scanf("%d", &b);
				G[i].push_back(b);
			}
		}
	}
	bfs();
	return 0;
}