1083 List Grades (25分)

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name[N] ID[N] grade[N]
grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade's interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student's name and ID, separated by one space. If there is no student's grade in that interval, output NONE instead.

Sample Input 1:

4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100

Sample Output 1:

Mike CS991301
Mary EE990830
Joe Math990112

Sample Input 2:

2
Jean AA980920 60
Ann CS01 80
90 95

Sample Output 2:

NONE

题目描述:题目给定某些学生的信息,包括姓名、课程号、课程得分,现在给定一个区间的分数,若有学生分数在给定区间内,则输出该学生的姓名及性别。没有则输出NONE。


输入:第一行n表示学生信息个数。接下来n行提供学生信息。

输出:输出分数在给定区间分数的学生信息,输出时按成绩递减输出,若没有符合的学生,输出NONE。


解题思路:写个cmp函数比较排序一下就行了。


#include<bits/stdc++.h>
using namespace std;
struct node{
	string name, class_name;
	int score;
};
vector<node> v, List;
bool cmp(node a, node b){
	return a.score > b.score;
}
int main()
{
	int n, l, r;
	node t;
	scanf("%d", &n);
	for(int i=0; i<n; i++){
		cin >> t.name >> t.class_name >> t.score;
		v.push_back(t);
	}
	scanf("%d %d", &l, &r);
	for(int i=0; i<n; i++){
		t = v[i];
		if(t.score >= l && t.score <= r){
			List.push_back(t);
		}
	}
	sort(List.begin(),List.end(),cmp);
	if(List.size()==0) printf("NONE");
	for(int i=0; i<List.size(); i++){
		cout << List[i].name << " " << List[i].class_name << endl;
	}
	return 0;
}