1089 Insert or Merge (25分)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

考察插入排序和归并排序

输入:第一行数组有n个数,第二行为需要排序的数组,第三行为已部分排好序的数组。

输出:判断输入的第三行数列是依照哪种排序规则进行排序的,并输出下一步排好序的数列

注意:测试点4,给出的数组序列可能存在相等元素。


解题思路:首先要知道插入排序和归并排序的排序方法、步骤。

插入排序:从需要排序的数组索引0开始进行排序。以样例1为例:

原始数组:3 1 2 8 7 5 9 4 6 0

1)3 1 2 8 7 5 9 4 6 0---对 (索引0) 的元素进行排序

2)1 3 2 8 7 5 9 4 6 0---对 (索引0~1) 的元素进行排序

3)1 2 3 8 7 5 9 4 6 0---对 (索引0~2) 的元素进行排序

...

归并排序的思想:

1)将数组元素两两进行排序

2)将数组元素44进行排序

3)将数组元素88进行排序

若最后一组不够元素,也要将他们进行排序


#include<bits/stdc++.h>
using namespace std;
vector<int> a, b;
int n, g;
int judge(){
	int t;
	t = b[0];
	for(int i=1; i<n; i++){
		if(b[i]>=t){
			g = i;
			t = b[i];
		}
		else break;
	}
	for(int i=g+1; i<n; i++){
		if(a[i]!=b[i]) return 1;//Merge
	}
	return 2;//Insert
}

void solve1(){
	printf("Merge Sort\n");
	bool f = true;
	int t = 1;
	while(f){
		f = false;
		for(int i=0; i<n; i++){
			if(a[i]!=b[i]){
				f = true;
				break;
			}
		}
		t*=2;
		for(int i=0; i<n; i+=t){
			if(i+t<n) sort(a.begin()+i,a.begin()+i+t);
			else sort(a.begin()+i,a.begin()+n);
		}
	}
	for(int i=0; i<n; i++){
		if(i) printf(" ");
		printf("%d", a[i]);
	}
}

void solve2(){
	printf("Insertion Sort\n");
	sort(b.begin(),b.begin()+g+2);
	for(int i=0; i<n; i++){
		if(i) printf(" ");
		printf("%d", b[i]);
	}
}

int main()
{
	int k;
	scanf("%d", &n);
	for(int i=0; i<n; i++){
		scanf("%d", &k);
		a.push_back(k);
	}
	for(int i=0; i<n; i++){
		scanf("%d", &k);
		b.push_back(k);
	}
	g = 0;
	int flag = judge();
	if(flag==2) solve2();
	else solve1();
	return 0;
}