1129 Recommendation System (25分)

Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user's preference by the number of times that an item has been accessed by this user.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers: N (≤ 50,000), the total number of queries, and K (≤ 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing -- for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

Output Specification:

For each case, process the queries one by one. Output the recommendations for each query in a line in the format:

query: rec[1] rec[2] ... rec[K]

where query is the item that the user is accessing, and rec[i] (i=1, ... K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

Sample Input:

12 3
3 5 7 5 5 3 2 1 8 3 8 12

Sample Output:

5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8

题目描述:更新推荐系统。

输入描述:第一行n为推荐数,m为最多推荐个数。第二行有m个值,为每次推荐的编号。

输出描述:输出此次推荐编号之前的排序,例如样例,第一个推荐编号为3,第二个推荐编号为5,应该从5开始输出它前面最优的推荐。

系统推荐排序规则:推荐次数多的排在前面,若推荐次数相同,则按编号从小到大排序。


测试点3、4容易超时,要找准遍历目标。


#include<bits/stdc++.h>
using namespace std;
int n, m, k;
map<int,int> p, pid;
struct node{
	int num, cnt = 0;
};
vector<node> G;
bool cmp(node a, node b){
	if(a.cnt!=b.cnt) return a.cnt > b.cnt;//降序 
	else return a.num < b.num;//升序 
}
int main()
{
	map<int,int>::iterator it;
	scanf("%d %d", &n, &m);
	for(int i=0; i<n; i++){
		scanf("%d", &k);
		pid[k] = i;
		node t;
		if(i){
			printf("%d:", k);
			for(int j=0; j<m&&j<G.size(); j++){
				printf(" %d", G[j].num);
			}
			printf("\n");
		}
		p[k]++;
		t.num = k; t.cnt = p[k];
		bool flag = true;
		for(int j=0; j<G.size(); j++){
			if(G[j].num==k){
				G[j].cnt = t.cnt;
				flag = false;
				break;
			}
		}
		if(flag) G.push_back(t);
		sort(G.begin(),G.end(),cmp);
		if(G.size()>m) G.pop_back();
	}
	return 0;
}