1130 Infix Expression (25分)

Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

data left_child right_child

where data is a string of no more than 10 characters, left_child and right_child are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by −1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.

infix1.JPG infix2.JPG
Figure 1 Figure 2

Output Specification:

For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

Sample Input 1:

8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1

Sample Output 1:

(a+b)*(c*(-d))

Sample Input 2:

8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1

Sample Output 2:

(a*2.35)+(-(str%871))

题目描述:二叉树,以算式格式输出。

输入:第一行n为节点数,接下来n行,表示第i个结点的值、左右节点编号。

输出:算式格式输出。


解题方法:题目没有给出根节点的编号,所以需要先求出根节点编号;得到树的中序遍历,之后得到算式还难吗?


方法一:

#include<bits/stdc++.h>
using namespace std;
int n;
const int maxn = 100;
string ans="";
struct node{
	string ch;
	int l, r;
};
vector<node> tree(maxn);
bool vis[maxn];
void bfs(int index){
	queue<int> q;
	q.push(index);
	while(!q.empty()){
		int u = q.front(); q.pop();
		vis[u] = true;
		node t = tree[u];
		if(t.l!=-1) q.push(t.l);
		if(t.r!=-1) q.push(t.r);
	}
}
void get_inorder(int index, int g){
	if(index==-1) return ;
	node t = tree[index];
	if(tree[index].r!=-1&&g>1) ans += "(";
	get_inorder(t.l,g+1);
	ans += t.ch;
	get_inorder(t.r,g+1);
	if(tree[index].r!=-1&&g>1) ans += ")";
}
int main()
{
	scanf("%d", &n);
	int root;
	for(int i=1; i<=n; i++){
		getchar();
		node t;
		cin >> t.ch >> t.l >> t.r;
		tree[i] = t;
	}
	for(int i=1; i<=n; i++){
		memset(vis,false,sizeof(vis));
		bfs(i);
		bool flag = true;
		for(int j=1; j<=n; j++){
			if(vis[j]==false){
				flag = false;
				break;
			}
		}
		if(flag){
			root = i;
			break;
		}
	}
	get_inorder(root,1);
	cout << ans << endl;
	return 0;
}

方法二:

#include<bits/stdc++.h>
using namespace std;
int n;
const int maxn = 100;
string ans="";
struct node{
	string ch;
	int l, r;
};
vector<node> tree(maxn);
bool vis[maxn];
void get_inorder(int index, int g){
	if(index==-1) return ;
	node t = tree[index];
	if(tree[index].r!=-1&&g>1) ans += "(";
	get_inorder(t.l,g+1);
	ans += t.ch;
	get_inorder(t.r,g+1);
	if(tree[index].r!=-1&&g>1) ans += ")";
}
int main()
{
	scanf("%d", &n);
	int root;
	memset(vis,false,sizeof(vis));
	for(int i=1; i<=n; i++){
		getchar();
		node t;
		cin >> t.ch >> t.l >> t.r;
		tree[i] = t;
		if(t.l!=-1) vis[t.l] = true;
		if(t.r!=-1) vis[t.r] = true;
	}
	for(int i=1; i<=n; i++){
		if(vis[i]==false){
			root = i;
			break;
		}
	}
	get_inorder(root,1);
	cout << ans << endl;
	return 0;
}