1155 Heap Paths (30分)
In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))
One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.
Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.
Output Specification:
For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.
Finally print in a line Max Heap
if it is a max heap, or Min Heap
for a min heap, or Not Heap
if it is not a heap at all.
Sample Input 1:
8
98 72 86 60 65 12 23 50
Sample Output 1:
98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap
Sample Input 2:
8
8 38 25 58 52 82 70 60
Sample Output 2:
8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap
Sample Input 3:
8
10 28 15 12 34 9 8 56
Sample Output 3:
10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap
题目描述:先理解堆的定义,堆分为最大堆,最小堆。题目给出一组数,有可能是堆或不是。如果是堆,则表示树的层次序列值。堆的构建是在满二叉树的基础上的,所以比较容易判断是最大堆还是最小堆。
最大堆:root结点的值大于其左右子结点的值。
最小堆:root结点的值小于其左右子结点的值。
解题思路:用数组存题目给出的树,一般舍去索引0,从1开始存值,当root索引为index时,左节点索引为index*2,右节点索引为index*2+1。判断v[index]的值是否都大于v[index*2]、v[index*2+1],如果是就是最大堆;判断v[index]的值是否都小于v[index*2]、v[index*2+1],如果是则为最小堆。如果都不是最大堆、最小堆,输出Not Heap。
并且题目要求输出根节点到叶子结点的路径,输出顺序是右大于左。
#include<bits/stdc++.h>
using namespace std;
int n;
vector<int> v, tv, ttv;
vector< vector<int> > ans;
int judge(){
int f1=true, f2=true, l, r;
for(int i=1; i<=n; i++){
l = i*2; r = i*2+1;
if(l<=n){
if(f1&&v[i]<v[l]) f1 = false;
if(f2&&v[i]>v[l]) f2 = false;
}
if(r<=n){
if(f1&&v[i]<v[r]) f1 = false;
if(f2&&v[i]>v[r]) f2 = false;
}
}
if(f1==true&&f2==false) return 1;
if(f2==true&&f1==false) return -1;
return 0;
}
void dfs(int index){
int l=index*2, r=index*2+1;
tv.push_back(v[index]);
if(l>n&&r>n){
ans.push_back(tv);
return ;
}
if(r<=n){
dfs(r);
tv.pop_back();
}
if(l<=n){
dfs(l);
tv.pop_back();
}
}
int main()
{
scanf("%d", &n);
v.resize(n+1);
for(int i=1; i<=n; i++) scanf("%d", &v[i]);
int flag = judge();
dfs(1);
for(int i=0; i<ans.size(); i++){
for(int j=0; j<ans[i].size(); j++){
if(j) printf(" ");
printf("%d", ans[i][j]);
}
printf("\n");
}
if(flag==0) printf("Not Heap\n");
else if(flag==1) printf("Max Heap\n");
else if(flag==-1) printf("Min Heap\n");
return 0;
}